Winter Update - Known Bugs & Issues

6 months ago

 Angbi's bones 


I return the bones... the dialog starts etc... but i get nothing as reward, the bones are permantly stuck to my characters, and the only thing the vendor says after is about opening the shop screen...while still keeping the exclamation mark and the quest in my journal.


Also in bonekeep i a found an andventures journal which also does nothing and it is stuck in our inventory as a quest item.


And...for last. The knock wizard spell didnt worked in all the bonekeep chests etc...it is like untargetable.

Bourgui
Level 9
6 months ago

@ David Seraph

You must keep the quest, this time for the fourth gem in Manacalon Ruins.

patrycz
Visitor
6 months ago

It is a minor issue, but can be potentially annoying: if you manage to kill enemy on destructible platform and then destroy the platform, the loot remains suspended in the air. Happened to me in Caer Lem during Brimstone Viper encounter: Viper died over one of the traps. Disarming the trap made the loot unobtainable at the moment. Another time it occured when i fireball'd a pack of goblins in Tirmarian monastery location: A goblin was standing on destructible platform while fireball killed it and broke the platform simultaneously. At this point fly spell allowed me to obtain the loot.

wowalive
Level 3
Steam Link Newsletter Link
6 months ago (edited)

Hi,

I finished once Solasta. I played it a second time.

This time the negotiation with the female vampire failed in the dark castle. But even though she shouts "Kill them all", they didn't attack at the end of the scene. I guess it's a bug and maybe because we were all in "stealth" mode?

Another problem: I kill the wizard/big boss in the black castle. Explore all the rooms. Try the different accesses. But for the progress of the quest, I got stuck with the status "Find access". So the quest could never be validated.

Last bug : I save my progress. Then, my thief drank the spider potion. Then I decided to reload my backup. The data is corrupted :-( Even after following the instructions on the forum and checking the integrity of the files, the problem remains.

I hope these bugs will be fixed in a next release. I was playing the 0.4.2.1 version (the last one)


Boukenka

FormulaZero
Visitor
6 months ago (edited)

My cleric is unable to create a scroll of cure wounds despite having all the ingredients and meeting any/all prerequisites. It thinks he does not have cure wounds prepared even though he does.

I have had the same thing on one run-through with crafting healing potions. This seems to have been because I didn't have a wizard on that runthrough (on previous runthroughs the wizard seems to have started with crafting instructions for healing potions) so I had to buy the crafting instructions from the magic bod in the marketplace. When I try to craft the potion it thinks that my cleric doesn't have the 'cure wounds' spell, even though he does. However, if I swap to my paladin then she does have the 'cure wounds' spell, it says, although she doesn't know how to make potions so that doesn't directly help.

So my guess is that there are two spells both called 'cure wounds' - one for clerics and one for paladins - and that the crafting instructions sold in the marketplace reference the wrong one, whereas the instructions that wizards start with are correct.

Still bugged in patch 0.4.21, as is the crafting formula for the healing potion. The latter used to work with the crafting book that elven wizards start with but seemingly no longer. This makes adventuring with a strength-based party even harder than it already was.

EDIT: Not quite so simple, it seems. If I create my own characters crafting for both cure wounds scrolls and potions is still bugged. If I use the pre-rolled ones the cleric has the crafting book for the cure wounds scroll and that works fine. However the wizard no longer has any crafting books, nor the scroll and potion kits, but once they have been bought then they all seem to work fine for the pre-rolled party. I'll continue to experiment.

EDIT2: Sigh! This seems to be working now. A quick timeline in case it helps anyone: when I loaded up in v0.4.21 I started a new adventure with my existing characters and Cure Wounds wasn't available. So I tried creating four new characters and started a new adventure with them - crafting Cure Wounds scrolls and potions still didn't work, not even for a paladin. So I deleted all my old characters and tried with the pre-rolled ones - the Cure Wounds scroll crafting now worked; the pre-rolled wizard didn't have the crafting books any more, but when I bought them they now worked. So I created four new characters and started a new adventure with them, choosing the backgrounds which gave my spell users the best potion and scroll kits - crafting of cure wounds thiings now works perfectly: even my Paladin can create healing potions. So maybe the answer is that you have to delete all your personal characters from previous versions before starting again from scratch? Or maybe it's to do with backgrounds - I don't know. Anyway, crafting is now working for me again - my party thanks you.

Same issue here (with a hill dwarf lawkeeper SUN cleric), my paladin is flagged for the cure wounds spell and the cleric is not, even if the spell is prepared, but:

1. In another game, my hill dwarf lawkeeper LIFE cleric is able to craft both cure wounds scrolls, bless scrolls and healing potions (the other cannot). Life clerics have both cure wounds and bless as domain spells and are always prepared.

2. Both my paladin and my cleric started with the crafting book for potion of healing, and in the one i cannot craft i things i think i read the book with the paladin

3. Both characters were created on the last patch

Is it tied to the reader? EDIT: started two games to test the clerics and made them read the book: only the LIFE cleric can craft. Most probably tied to always prepared spell.

Another bug i have to file is that not always the character with the most notable skill is selected, for example in Caer Lem when talking to Daliat the Persuasion option is given to my cleric (+0) instead of my paladin (+5). One is LN, the other LG. Is it tied to alignment / personality? Plus the insight check with Lisbeth is gone and the dialogue options does not show the skill that's been used in that dialogue.

silverblade
Level 10
6 months ago

After completing Caer Lem and speaking with the Council, you are supposed to speak with either Beryl or Daliat.  When I open the map, I noticed the box with the fast travel arrow is under the exclamation mark where Daliat is located.  It's very difficult to click the box because of the exclamation mark.  I suggest the fast travel arrow box be moved a little so they don't interfere with each other.

sarge33rd
Level 12
5 months ago

Upon returning to the guild with Angi's bones; I got the monetary reward and the guild promised to bury Angi's remains...but that will be difficult for them to do, since the bones remain in my inventory and I cannot give/sell them to the guild.(I know, quest items are locked. But this one, should be removed when they guild promises to give Angbi a proper burial)

terrymaster
Visitor
5 months ago

Not sure how it happened, or if it was supposed to, but I was able to fast travel from the origin city Caer Cyflen right after the cutscene that explains the fast travel gates and how nobody had found one yet. This was available via dialogue options from somebody in the square. The two options were Kythaela's family secret gate in Coparann and the Wizard's tower. I had not previously been to either of these locations on foot. Starting with the Coparann gate first, the cutscene failed to load properly and I was stuck in the room (no way to open from the inside and the gate did not work in the other direction). Second option to the wizard's tower teleported in, was able to clear my way outside, and the game popped up the world map with my characters still showing in Caer Cyflen. At this point I decided to carry on the main quest the "right way" - fast forward to joining up with Kythaela, we get all the way to the Wizard's tower the usual way this time, and opening the door to the dragon's room, we get a short cutscene with her and the floaty emo vampire guy, but no battle commences and we're stuck in that room forever it seems with no way to open the door.

5 months ago (edited)

The "Might of the Iron Legion" Feat doesn't actually grant proficiency with Heavy Armor, as the description states it does.

But it does properly grant proficiency with swords.


Also: The "Sparkle" spell doesn't work on some objects, such as some of the torch sconces in the basement of the Dark Castle.

Also: The "Identify" ritual lists pearls as a required material component, but you can cast it without them.


Also: The "Paralyzed" status effect isn't removed when a character successfully saves against the effect. The afflicted character has to wait the full duration of the effect before it is properly removed.

Also: Returning Angbi's bones to the city triggers a cut scene, but the quest is not cleared. No reward is given, the exclamation point remains above the recipient's head, and the bones remain in the player's inventory.

5 months ago

The "Craft Empress Garb Chain Shirt" recipe requires "Empress Garb Chain Shirt" as an ingredient. I'm assuming that's unintended.

Scribing "Fog Cloud" into my spell book with a scroll added it to my spell list. Scribing a Scroll of Fog Cloud afterwards seems to have then removed it from my spell list.

Selecting "Spy" as a background does not grant access to the Spy Code language during character creation.

Spells or items that grant increased Max HP - such as "Aid" or the "Belt of Dwarven Kind" - do not seem compatible with some methods of HP recovery. For example, Aid increases Max HP by 5, but that 5 HP cannot be recovered using hit dice during short rests.

Brandil Sharpleaf's will appears multiple times throughout the Monastery quest, sometimes with odd names such as "Imperial Mage Report." The first time is in a chest near the lone minotaur near the mausoleum, the second and third copies are buried in caches in the area leading to the tower.

Crossbow bolts and certain other projectiles don't seem to drop properly against enemies in the Dark Castle. They appear to always drop arrows, rather than any other projectiles they are struck with.

Redglyph
Level 14
5 months ago

Hello there folks!

Here is a new updated list of known bugs and issues:

Regarding Early Access and reporting bugs & suggestions.

I've tried to report them here and those forums don't provide a good way to keep track of posts. I'm not sure if you read them (that must take a lot of time), and I'm not sure if we have to re-post bugs after updates, in case the previous posts are lost.

I tried in Steams forums but there's simply too much trolling over there.

I'm not used to work like that, in development I'm using bug tracking software to get a clear vision on what's know and what's not. So I'll just uninstall Solasta and wait for the release, best for everyone I think. Not that it'll make any difference for you (not even sure you'll read any of this anyway), but others may feel the same so there you are, some meta-feedback ;)

5 months ago

I've been able to use the Caer Cyflen Major Gate to access the three others from just after getting the crown; the game seems to realise this as the locations are tagged with 'should not be displayed' when highlighted in the menu.

5 months ago

I haven't seen anyone else report this so far. I ran into a bug in the vendor screens where, if you mark an item for sale, then change to a different character without completing the sale, the items marked for sale disappear from the PCs' inventory. I noticed that they come back if you cancel the sale completely, but if another transaction is completed without cancelling, the items initially marked for sale just vanish completely. Anyone else having this issue?

purplemurex
Level 1
5 months ago

Bug: Small PCs can use heavy weapons without disadvantage (specifically halfling ranger using longbow on the first bandit fight after you leave the starting city. Only had blue dice roll, and chat log displayed no source of advantage or disadvantage, same for hover over)

Possible bug/difference to 5e: Wights suffered light sensitivity from campfire light (at night in random encounter) when usually in 5e they only suffer sensitivity from sunlight specifically. In addition their AI/tactics may be off as they approached the party walking into the campfire light.

DayDaemon
Visitor
5 months ago

Master Dackin in Caer Cyflin is bugged.  Wrong flavor text and won't interact.