V.1 & V.1.0.18 : Game now Overheats GPU/CPU. BIOS forced Shutdown. GTX 3090

DailyLama72
Level 5
1 month ago (edited)

For information, they mention this workaround in the last hotfix, known issues: https://steamcommunity.com/games/1096530/announcements/detail/5391352763132294661

For everyone using the XBOX Game Pass for PC version and is still on 1.0.17m: you have to open Solasta in the Microsoft Store App. There it uodates to 1.0.22 :)
Why the XBOX app does not offer update is a mystery, since Auto-Update is enabled.


rohan
Level 1
1 month ago

As was said by others, it seems to be certain areas. 


Or more specifically certain FX/graphics that seem to be triggering the sudden rising overheat.


Even if I low graphics settings/FPS it will still suddenly shoot up in temperature, but just to a lower level.


It's as if one FX is caught in a loop.


3 areas I've had it in so far.


1. Waterfall

2. North side of copperfield? (coppersomething)

3. In the masters tower, just outside the library

Redglyph
Level 14
1 month ago

@IXI the links are at the bottom of this site, maybe it's possible to send them on Steam too, I don't know if that's possible to upload files there as I usually avoid the place. On Discord at least, you can discuss with them, it's more efficient.

May I ask why the devs dont watch the forum? Why does the forum have a bug section if it's not watched? I have no idea what discord is and how it works :(

I know, it frustrates me as well to have reported many bugs in vain. I've tried in the Steam forums once, but it wasn't any better and you also have to deal with the inevitable trolling over there.

Using Discord is pretty easy, it's a chat system so chances are people will quickly react to anything you report or ask.

You can click on the Discord icon at the bottom of the page here (5th one at the moment) to get on their Discord server, one of the channels is dedicated to bugs. If you don't have an account, creating one is rather quick and painless. There is a Discord Windows app but I never installed it, it's fine in the browser.

Redglyph
Level 14
1 month ago

For all I know, this bug is still not fixed.

Using double buffering is not a solution, introduces lag and has strange effects on camera panning, there's definitely a performance problem in that mode.

The only choice seems to be a limit on the FPS in the nVidia control panel, but since I cannot see a way to display the framerate to monitor it, it's just a guess. Could not get feedback from devs about it.

Redglyph
Level 14
1 month ago

I did many tests, I'll put my findings here (I game them to TA on their Discord).

My hardware: RTX 3070, i7-10700K CPU @ 3.80GHz, 3792 Mhz, 8 Core(s), 16 Logical Processor(s)
In nVidia control panel, I'm capping to 60 FPS. I have tested by capping at 20 FPS and it is very visible, so I have no doubt this option works in single and double buffering.


I'm at the Dark Castle at night, near the pond, where I see the fire. Two of my characters have Light on them, and my rogue has a burning torch (I think that 2 or 3 burning torches would do the same). But I got the same problem on the edge of a simple random encounter map, so I'm pretty sure that the complexity of the map has little to do with it. I don't want to design a map in DM for that though, it's not my job.

Tests:

  • Changing: shadow quality, shadow distance, volumetric lighting, depth of field, ambient occlusion, anti-aliasing, vsync mode disabled / single => no noticeable decrease of GPU usage with FPS capped at 60 FPS, GPU is around 95% and fans full.
  • Disabling shadows altogether => reduction to 30-ish % (but not very pretty), still with FPS capped at 60 FPS 
  • Double buffering => the framerate is halved, so it's called "double buffering" but it's actually something entirely different. => reduction to 57% (but low framerate is not fun), still with FPS capped at 60 FPS 
  • Framerate capping at 30 in nVidia panel, similar reduction of GPU usage (and not fun either).

So disabling shadows completely is a work-around for now (just changing the shadow quality and/or distance to low does nothing for me).

I haven't tried other options in the nVidia panel, it's obviously something in the graphic pipeline linked to the shadows that made this problem appear since the last update in Early Access (since Spring update probably). Perhaps when they updated the version of Unity, but I cannot verify.


The feedback of Myzzrym is that they can't reproduce the problem with an RTX 3070 but are still investigating. Strange, but maybe with a very old CPU throttling the GPU, it would be harder to get the problem.

In any case, from the results above, I don't believe the problem is due to the GPU suddenly producing more than 100 FPS, since the problem is happening at 60 FPS and wasn't happening in EA.

Redglyph
Level 14
4 weeks ago (edited)

Found another cause of GPU overstress, it happens near the waterfall in the Tarmarian ruins. There is no work-around for this one, you simply cannot avoid the GPU running at a constant 95% or more.

It is not justified by the graphics, and I never saw that in any other game using Unity, even more recent versions of it.

Redglyph
Level 14
1 week ago

The problem is still there in version 1.1.6 unfortunately, so still unable to play in decent conditions.

Redglyph
Level 14
5 days ago (edited)

I haven't checked in 1.1.8, pretty much given up on Solasta for now (especially with the lack of feedback from the devs).

If anyone has this issue, try disabling the shadows, it could be interesting to know

1) if the problem remains in the Tarmarian Ruins (the waterfall)

2) if the problem disappears everywhere else, from what I saw it was mainly due to multiple sources of light

Dragondeal
Level 4
1 day ago

Got a black screen and game freeze right on the last attack of the end fight, graphic card (RX 570) was near 100%. Decreased overall graphic quality by 1 and it worked, but even with medium settings the cut scene brings the card to 99%.