[solved] Corrupted files that are not corrupted?

Master Darek
Level 3
1 year ago (edited)

Hi adventurers! \o/

I need your assistance, please. I'm not sure what I did wrong...

Today, by curiosity, I tried to look for the two dungeons I created in my usercontent folder (C:\Users\Maske\AppData\LocalLow\Tactical Adventures\Solasta\UserContent).

I found them, and saw that they were .json files. So I though "Nice, if anyone wanted to create a dungeon without the dungeon maker, he would just have to type everything in a text file". Then I opened one of them with notepad, just to have a look, but didn't touch anything.

After that I navigated through the folders and found the character directory. And I thought "Ok, remember that character Darek? You actually misspelled and called him darek, with no capital. Let's try and change that, because that's annoying." So I changed both the name of the file and the first line IN the file (from darek to Darek, with notepad, still) and saved.

Now I can no longer play the game... It starts loading and then stops and tell me to check the integrity of my files.

Of course I went back to the character directory to change back what I modified (Darek > darek), then tried different times to check the integrity of the files with Steam (and I have no error, tells me everything is ok), I reloaded the game several times, and tried to reboot the PC, but nothing works.

I must admit I don't quite understand what's happening.

Any piece of advice on what to do/try? ^^'

Edit: Just in case, I just tried to make a backup and reinstall the game, but I think it also saved the corrupted file(s) that in reality are no more corrupted (which one.s, idk).

Edit n2: I uninstalled the game and redownloaded it completely from scratch. After installing, the problem is still the same... Maybe it's a problem with the autocloud that keeps loading corrupted files?

Edit n3: Problem solved! :D

If it happens to you, here is what I did: I cut the synchronisation with the steamcloud. I deleted my character file "darek.chr" (that was clearly the problem) in appdata (LocalLow\Tactical Adventures\Solasta\Characters) and then recreated a new one in game, with exactly the same name (misspelled the same way, no capital letter) to overwrite the old version. This way I had a brand new (and not corrupted!!) file in the character folder. Finally, I reenabled the autosync with the cloud, and voilà! It works very well now. What a story...! 24h without playing, hehe. That was hard! ;)