Palace of Ice bug soft-locked me out of progressing.

Samuel Roman
Level 1
3 months ago

I was playing through the palace of ice DLC when I to the part where you have to either side with Captain Ashdown or General Blunt in the Eastern Clan quest line. After killing the convoy I returned to Gallivan border but Ashdown didn't load in and all his cutscenes were skipped. The quest line still updated however. Since Ashdown didn't load in I couldn't arrest him or kill him so I killed General Blunt and then went to Glendale Caste. Ashdown didn't appear there either even though he is supposed to according to online sources. I cleared out the entire fortress killing the Gallivan General. After however you get a quest to leave the castle and when I tried to step in the area to leave the quest updated like I had left the castle but I got no prompt to leave the area and stepping on and off leave area also had no effect. So now I am stuck in the castle unable to leave, soft-locking the game. I have tried closing and reopening the game multiple times, loading different saves, and verifying the the integrity of the game files none of which have helped. I have a save from after clearing the convoy and and save from after killing the Gallivan General if there is anyway to recover either save that would be amazing.

3 months ago


Sorry to hear that you are having such troubles.

In order to investigate this issue more thoroughly, could you please send us your save at ?

You can find them in the folder  C:\Users\...\AppData\LocalLow\Tactical Adventures\Solasta

It would help us identify if anything might have occurred specifically in your run that might cause this issue.

Thank you for your time! 

3 months ago

While I am not having the issues that Samuel has in reference to Captain Ashdown, I am also stuck at the same point as him. I have sent my save file to the email referenced.