Mod subs not showing up on PC…

1 month ago

Went to make a multiplayer game on my PC today and none of my subscribed levels were shown. Just “??” where the should be. They show up fine on the Xbox Series S…

1 month ago


Sorry to hear that you are having such troubles.

Could you confirm us on which launcher the issue is occurring (Steam / Microsoft Store / GoG)? 

If it is Microsoft Store or GoG, could you try to log out / log in with to refresh the link between the account and the game ? Also to be sure, are you using any mods on PC? 

Thank you for your time!

3 weeks ago

Hi! I haven't played Solasta in a year or so and my group of friends wanted to get back into it but I could not open the game through steam. I was getting stuck at the 90% for about 10 minutes before I alt-f4d and attempted the below steps to fix with no solution:
1. Updated game drivers and restart pc (no success).
2. Verified game files (no success).
3. Uninstalled and reinstalled game (no success).
4. Deleted entire Solasta folder and verified game files (no success).
5. Uninstalled Solasta and reinstalled on another hard drive (from the D drive to the C drive with no success).

Unsure what to try at this point. I can not open the game so I can not play with my friends. Was really looking forward to it so if you have any further steps I could try would be super happy for them.


1 week ago

I am having the same issue on my xbox series s none of them are showing up I tried refreshing nothing, I tried resubscribing nothing, I tried relogging in nothing.  Ever since the newest update they haven't been loading up.