‘Kill The Soraks’ (Explore The Tower’ quest) cannot exit to map!”

3 months ago (edited)

Hey All,

I was doing pretty well, I had burnt through the “excavation site“ in the “explore the ruined tower“ quest and completed the library, you know, found all the rooms et cetera to open the door and then suddenly the combat was ridiculous I was hardly getting any hits in and getting my backside handed to me time and time again.
Anyway, i’ve tried for three days and I’m not quite sure what to do, they’re all good characters and I tried again and again to complete the “kill the Soraks“ quest to no avail….. it wouldn’t make any difference if I went back and restarted the quest because my characters are just not strong enough to defeat these particular Soraks……. with this in mind, I went back all the way to the excavatio site so I could leave and enter the Map and go and get some more experience and level up in a bit more before taking on these particular Soraks but I cannot leave the area and I refuse to lose all that experience, how is it that I cannot exit the excavation site!?  Advice please!


“A 1000 mice a tiger does not make”

Tenzhi
Level 4
3 months ago

Adjust the difficulty temporarily.

2 months ago (edited)

Thanks! Oh my God, I had to rinse and repeat until I won because I refused to reduce the difficulty as I thought that was cheating. However, much like the “souls” games repetitive action does have its place in RPG’s because although the learning curve is steep that way, the action cements in tactical knowledge which is required when playing a game like Solasta, an rpg in a class of its own.


“A 1000 mice a tiger does not make”