Initial screen hangs and button click area changes or does not accept being clicked

1 year ago

On Steam version.

When I fire up Solasta the initial screen with adventure select and character select will glitch out after a single click.  All buttons sound like they are being clicked on but nothing happens when you do (or 95% of the time - occasionally it select a character to add to party but I have little control over who as it seems to select character randomly).  

Selecting continue adventure hangs immediately at the loading screen.  Attempting to load a save game fails at the loading screen as well.  

I have removed all mods and uninstalled Unity updater without change.  I have uninstalled the game without change.  I have checked file integrity at least two times.  I have tried windowed and unwindowed graphics.  

Character select somehow has 18th level character who will not allow me to make any further characters with a name ending in G-Z.  All newly created characters become a copy of that character (the character's name is Gwerm or something so that is likely why all letters after G is failing).  Uninstalling the game did not make the characters go away.  Removing various mods causes the modded characters to still be in the lineup just their class is a "--".  I have tried to delete the broken characters but the delete button does nothing.  


1 year ago (edited)

I found the game folder in Users and deleted all characters and saved games without a change.  The deleted characters still appeared in the selectable characters at start up.

1 year ago


We noticed some issues with Characters created with mods, they can make the Character Screen go haywire if the mods are not up to date or deleted. 

If the Characters reappear, it may be due to them being saved on the Cloud (and thus being redownloaded on your computer each time you launch the game).

If you are on Steam, right click on Solasta, pick "Properties" and in the General options, untick the "Keep games saves in the Steam Cloud". That will prevent Steam from redownloading your save files and characters.

From there, make sure you deleted the characters in the game folder, just like you did before, and try to launch the game again.

Let us know if it helped! If it did not, we'll investigate further.