Game crashes when clicking change campaign or dungeon maker

Level 1
2 months ago (edited)

Anytime I load up Solasta and try to access the dungeon maker or change the campaign when making a new adventure my game freezes and does not allow me to do anything. I have tried to verify my files and have reinstalled the game. Neither of these have changed anything. Game Version 1.4.33-Public

1 month ago


Sorry to hear that you are having such troubles.

There is a possibility if you used the Dungeon Maker that it might be linked to the "Scimitar of Speed" issue (fortunately, should be fixed once the next patch is up - if it is looted inside of a chest, the campaign can get corrupted and prevent the DM / New adventure from being accessible since it tries to load every campaign but got a corrupted one).

If you could, check in C:\Users\...\AppData\LocalLow\Tactical Adventures\Solasta\UserContent\Campaigns and try to remove any campaign that you think might contain this item (also, if you did subscribed to any campaign on the workshop, removing them might help), it should hopefully fix your issue.

Thank you for your time!

King Fiain
2 weeks ago (edited)

Hello! Love your team's work! For a more indie studio you guys have done a spectacular job! It really captures the ttrpg-feeling like no other game I have played. I'm planning on loading up Palace of Ice on release. I am having the same issue as the person above. For context I play on PC through Xbox and have tried it on console as well so I don't know if that might be coming into play. If I have to delete all my save data so be it; I just want to be able to play the DLC immediately when it goes online. The problem started with me creating a campaign that fits the description and I am having the same exact issue today. I tried the steps above and now am reinstalling the game all together.

Half-Orc Pact of the Blade Timekeeper