"Error: Loading Failed" appears even before selecting a save

2 years ago

Hey there, I was playing the game when it suddenly crashed (I started a fight against some Soraks after some kind of library).
Whenever I try to start the game now, I only get the message "Error: Loading Failed" and the game tells me that I should verify my game files. I've already verified my game files and I uninstalled and re-installed it again.
I  would be ok with starting from scratch, but even that is impossible -  as soon as I start the game it crashes. I can't even load another file  or start another campaign or anything.

Important: I cannot launch the game. As soon as I click "play" on Steam and the game loads, the error appears. The error appears even before I load any saves or anything.

What can I do now? Someone said I should try to delete my game files, but I don't know where to find them or whether that would even help

2 years ago

Same here don't know what to do. Try all the above minus delete the game files, and i too can't find them.

Level 14
2 years ago (edited)

The game files are there, but be sure to know what you're doing:

%USERPROFILE%\AppData\LocalLow\Tactical Adventures\Solasta

(%USERPROFILE% is the env. variable, for ex. c:\Users\)

1) You could start by moving the files in Save Files elsewhere and launch the game. Perhaps one of them is badly corrupted and crashes the game when it first reads the saved files (when it's creating the list to display in the game). That would be my first guess. If that solves the problem, then move the files progressively back there, except the most recent one.

If that still works, please give the corrupted saved file to the devs, that will help them! Unfortunately it's not possible in these fancy forums, but it's possible on Discord. Or by asking them an email address.

I've heard someone else who had a corrupted saved file. I thought this problem had been solved since the Spring update, but apparently there is still something fishy. Check that all characters are selected when you save (this bug occurred when arriving at a new location back then, sometimes the characters were not selected).

2) If that's not helping, you could uninstall the game, remove the entire Solasta directory, and reinstall the game. Maybe it's not necessary to uninstall / reinstall, you could first try to remove the directory then launch the game, with chance it will regenerate the required files, but no guarantee.

2 years ago

Thanks for your input. I now tried moving the Save Files, but upon starting the game they are automatically restored (the folder goes from being empty to having all the files back in it).

2 years ago

Solved, if you are playing from steam disactive the cloud saves, if not even if you delete the corrupted saves they will be restored.