Error & freeze because Solasta.exe is not responding

2 months ago

A friend and I played through the Solasta tutorial in July 2022 with no issue. We started a new multiplayer game Dec 23, 2022, and I experienced the "Solasta.exe is not responding" error shortly after we completed the Caer Lem quest. We thought that it might be his hosting the game (he's in the UK and I'm in the US) and we swapped host duties. Even with my hosting the session, I still got the error. We switched over to the Lost Valley campaign and I got the error after the conclusion of Fairblade hiring our party to find Marin Ving (so basically, at the beginning of the game). The error pops up and freezes my game whether I host, my friend hosts, or I'm in single player.

I'm on an ASUS TUF A15 laptop running Windows 10. Game version is 1.4.32.

I have tried the following:

  1. Verifying integrity of local files (always comes back with no issue)
  2. Turning down graphics settings
  3. Clearing Steam cache
  4. Uninstalling & reinstalling (several times with cache clear-outs, Steam restarts, computer reboots, you name it)
  5. Verifying all software and drivers are up to date
  6. Whitelisting the game's folder in my virus protection
  7. Reinstalling the game with virus protection turned off (it was suggested in a post somewhere that anti-virus software might have been blocking certain files)
  8. chkdsk /f

I read that one "solution" was to turn off networking, but that's impractical with a wireless headset, wireless mouse, and needing a network connection for a multiplayer campaign.

Any other solution that would make this enjoyable game actually playable?

2 months ago (edited)

Thanks for the useful information

2 months ago


Sorry to hear that you are having such troubles. Seeing all the steps you followed, there are a few additional steps that worked for other users that might be able to help you I hope :

1. Deactivate the cloud both on the game (Proprieties -> General -> Steam Cloud) and on the application (Steam -> Parameters -> Cloud -> Uncheck "activate Steam Cloud synchronization with compatible applications")

2. Remove the entire Solasta Folder from C:\Users\...\AppData\LocalLow\Tactical Adventures\Solasta (make a copy of it elsewhere to not lose all your data)

3. Start it to see if it works

4a. If it worked, one of your files might be corrupted with a recent update. If you have any characters or saves you whish to add back, I would advise to only add back the "Characters" folder and "Saves" folder from the "Solasta" folder, and checking in between that everything still works (to see if one of your character or save is corrupted). 

4b. If it is still not working, I would advise to uninstall / re-install the game with the cloud deactivated to check if it works this way at least. 

Other solutions that worked for some users : 

1- Update the graphic card drivers

2- Add an exception to their anti-virus (especially if using Avast or Norton). 

If none of that works, could you please send us your Player Log at ?

You can find this file in C:\Users\...\AppData\LocalLow\Tactical Adventures\Solasta

(To be safe, you can send us your "Logs" folder if there is anything as well as the Player.txt and Player-prev.txt)

Thank you for your time!

2 months ago

Thank you so much for those suggestions. I’ll give them a try and report back.

2 months ago

I still can't get the game not to freeze. 

However, I do have a question before I send the log: does it matter that Slasta_COTM is on my D: drive with all other Steam games, but the Tactical Adventures\Solasta is on my C: drive?

2 months ago

Sorry to hear it did not work, 

The installation drive should not be a problem, if you have room on your C drive you could always check to re-install it there just to be sure but I have never encountered / saw anyone with an issue linked to using 2 drives before. 

Also, an additional step that I hope can help : once the exception is created for the anti-virus (on the folders directly - in AppData and SteamLibrary, not just the .exe), un-installing / re-installing can help (another user got an issue recently with missing .dll that were deleted by their anti-virus).

I hope this will work for you as well, and if it does not, if you could then send us your logs please, it would help us try to identify the cause.