Early Impressions

sarge33rd
Level 13
6 months ago (edited)

I was going to try bare rooms and design their interiors myself, but booting up the DM and looking at what is available, only what can be seen in the outfitted rooms exist as options.

No beds/cots/sleeping mats for indicating a "barracks".
No weapons racks for an armory.
No tables/benches for a mess facility.
No stalagmites/stalactites, streams etc for caverns.

All in all I applaud the hell out of the T.A. team for designing and bringing us one hell of a game/game system. I truly, truly do. Then I echo that sentiment, for listening to your players and doing everything in your power, to give us what we ask for. I am 150% sincere, in those kudos. That said...the DM wasn't ready for launch.

That I see, there is no means of connecting a door on "this" map, to a door on "that" map, and/or stairs going up/down to another level. EDIT: My apologies. I found that now. One must create the destination to be linked, prior to linking. That was the catch I was missing. You cant link it to a destination which has yet to be created. duh.

No means exists that I can see, for inserting your dungeon, into the world of Solasta, so that it can become a side quest, or even major quest in its own right.

No means exists for opening an existing Solasta encounter IN the DM, and tweaking said encounter. (Again I will use the end encounter from the winter update as an example. I'd add 2 more Vampires and 4 more Blood Brood to that encounter. As it stands now, it is FAR too simple and anti-climatic. It could be, that such an increase is too damn much. But there is only one way to know for certain. Perhaps adding 1 Vamp and 2 Blood Brood would be sufficient, perhaps not. But that one definitely needs to be toughened up some, IMHO. I mean, they (the bad guys) subdued a Dragon FFS.

The DM does GREAT, at allowing you to add a wide variety of encounters, and an equally wide variety of treasure. Kudos again for that part. And I know, this is the early version of the DM, I understand that. But to be functional, it needs more than one environ and it HAS to be both multi-level capable AND insertable into the Solasta game world.

Yes, that last 'requirement', poses potential compatibility issues between mods/designs.. (ie, multiple dungeons trying to access the same point in Solasta, as their starting point.) Mod conflicts, is something gamers have battled since the days of Morrowind if not longer. We're both use to it, and expect it will happen from time to time. BUT, with a fully functional DM, one could open the conflicting mod and CHANGE the starting point! BOOM! No more conflict) This would of course, require that X,Y,Z coordinates on the world map be plotted out and that the DM include tags for placement on the world map as to the starting point (and possible exit points if different from the starting point) of the DM provided adventure are located.

To close, I do not want this post to be taken as an overly critical commentary. My intent, is precisely the opposite. I have extremely high hopes for this game/game system. Solasta has filled a void which has existed for FAR too long and you folks at T.A. are doing a tremendous job with this undertaking. I just REALLY want to see this thing go "to the next level", and these are how I see that happening. 

sarge33rd
Level 13
6 months ago (edited)

I apparently must wait for ver 2. I am utterly unable, to link 2 maps, if those maps have content.

Map 1, I must use a 0 as the entry index for the party start point. If I insert a 1, I get the blk/gry polys and a dead party. I then built maps 1, 2 and 3.

Went to map 2, inserted a landing point (entry) from map 1; index value 0 (like on map 1) and then went back to map 1. Inserted an exit, linked to map 2, index 0. And a landing on map 1 index val 1. Back to mapa 2, insert an exit to map 1, entry point index 1. On to map 3. Insert a landing on map 3, index val 0. Back to map 2. Exit, tied to map 3, index val 0 and a landing point index val 1. Back to map 3, exit to map 2, index val 1.


Failed to load upon completion of map 1. Said to verify files. I did, they did.


Go back in and delete all entry/exits. Repeat process, giving initial landing values of 1 on maps 2 and 3 and a 2nd entry point on map 2 with a val of 2. 


Run through 1 again, and fails to load, verify files. I did again, they verified again.


Back into the editor, delete again, Reinsert with progressing values, initial landing on map 2, val 2. Return landing on map 1, val 3. Land on map 3 at val 4, return to map 2 at val 5.


Rerun the dungeon again...fails to load.


Back into the editor...delete ALL entry exit pints...relocate them on maps 1, 2 and 3, repeating the process above to ensure a landing point is designated on a map, prior to creating an exit point which points TO that landing spot.


Samee error...wont load. Verify files.


So I build 2 maps...1 room ea, no content...initial entry pt index 0. Landing on map 2, index 0. Back to test map 1, exit to map 2, index 0, create a landing spot, index 1. Back to test map 2 and insert and exit pointing to map 1 landing index 1.


play test...works perfectly.


Back to my 3 map dungeon...repeat process as above...fails to load 2nd map, verify files.....


at this point, I know perfectly well WHY, my grocer sells me Jack Daniels by the gallon.

6 months ago

Get some Bushmills and drink real whiskey.

sarge33rd
Level 13
6 months ago

tried one last thing...put a room, nothing else on a map, then a lone room on another map. Link them. Did it work? Yep. Then a room on a 3rd map. Link to nr 2. Did it work? Yep. Now a room on map 4 and link to 3. Did that work? Yep.


OK, now I built maps on 4 levels. No encounters, no treasures, no population; just 4 maps. Play test. Can the party move thru the 4 levels and back and forth? Yep.


OK good. Now populate our maps and enjoy...right?


Wrong.


Get to the lvl1 to lvl 2 transition that was working fine 2 hours ago?


Load Error.


I give up.

If anyone at T.A. wants my json files, give me an email to send the to and I will. But until vers 2 of the DM?


I'm done.

Tactical Myzzrym
Level 14
Tactical Adventures Dev
Discord Link Steam Link Newsletter Link Developer Badge
6 months ago

Thanks, we'll look into it!

sarge33rd
Level 13
6 months ago

Made a video of the DM, the values for the entry/exit points etc. Shows the load error. I also tried, off the recording, changing the values of the map 2 entry point to a 0 vs a 1 and the corresponding exit from map 1 to point to a 0 vs a 1. Same load error.


https://youtu.be/k7RWXL-iyeQ

sarge33rd
Level 13
5 months ago

can NOBODY tell me why I cant load a 2nd map once I populate the dungeon, though it would load PRIOR to populating the dungeon?