Early Access Launch - Known Issues

Tactical Myzzrym
Level 14
Tactical Adventures Dev
Discord Link Steam Link Newsletter Link Developer Badge
1 year ago (edited)

Hey there folks!

Here is a list of known issues that you may (or may not!) encounter during your Early Access run. Rest assured that we're working on fixing all of that!

Planned Improvements

  • "Hide" Action has not been implemented yet
  • Unconscious / Death System not fully implemented yet
  • Option to disable auto camera panning on screen borders not implemented yet
  • Difficulty Levels not implemented yet
  • Animation Speed to be adjusted
  • Spells range are not displayed on the battle grid yet
  • Unseen enemies currently take too much time during battles
  • Loading bars are not implemented everywhere yet
  • Dice Settings - Create a new design for selecting dice settings
  • Skills display - The skills matrix in the proficiencies stage / tab looks bland
  • Main menu buttons - Since the removal of pixel perfect mode, the main menu buttons do not have the same frame thickness in every direction
  • Console - Show the creature tooltip when hovering the creature name in the console
  • Feedback condition - Add a crossed-out text popup above character when a condition is removed
  • Short Rest - Click on the dice instead of the "roll" button to roll Hit Dice
  • Inventory Stacks - People can't figure out how to split stacks in the inventory
  • Inventory Identify - Right click an item in inventory and have a "Use Identify via Character X" when someone has Identify Spell
  • Inventory - Double clicking to equip item
  • Campaign screen - Add the console in the campaign view
  • Combat - Add an option to display hit chance % when aiming at an enemy
  • Loot - Add a function to loot all surrounding loot bags at once
  • Bestiary - The tooltips are missing from the bestiary elements
  • Caer Cyflen - Include the faction symbol on city map blueprint
  • World Map - Travel journal - 5% transparency fade on background, to better integrate
  • Character Background - Personality flags on the background cell are confusing, you would expect them to be on the right

Known Bugs

  • Some tooltips may be wrong
  • Some text may still be placeholder
  • FR / DE / CH text have some missing text and will display English instead
  • Upon interacting with a wall to access a secret passage, the secret passage animation may not play correctly
  • In Tower of Magic, Sorraks sometimes don't spawn correctly (they're stuck underground) - reload a save and it should fix itself.
  • Attacks sometimes pass through stone assets due to missing collision
  • Hostile NPCs can sometimes get stuck into the characters texture
  • Tall characters may be partially covered during cutscenes due to incorrect camera positioning
  • After some cutscenes, the camera may be placed into a wall or environmental elements
  • In Caer Lem, the Teleport stone is facing the wrong one
  • Some interactable elements may remain usable even after being used (such as levers) 
  • Some characters may not be sitting properly on benches
  • You can sometimes miss torches (because they have a hidden AC / Saves) 
  • Some interactions with the decor may have superflous animations
  • Some decor may be hovering without support
  • Some decor may have the wrong hitbox
  • Orcs walking animation look a bit funky
  • Clipping issues may happen with some characters / armor
  • Some weapons are improperly wielded / Some weapon animations are not correct
  • Protection Style / Block animation is weird.
  • Mana Lamps disappear (visually) when lit
  • Some monsters may move back and forth for no reason
  • You may get an error when reloading at very specific times
  • While concentrating on Detect magic and then looting a magical weapon the spell doesn't detect the newly acquired magic item without recasting it
  • You can lose your free action without modifying anything in our inventory
  • The "death throw" panel disappears very quickly and doesn't have time to be updated as it should
  • You can potentially crash if you read the death saving tooltip in the log during enemy's turn
  • The game sometimes crashes while quickly hovering the mouse towards the middle top of the screen
Mike Redmond
Level 1
Kickstarter Backer
1 year ago (edited)

This post has been deleted.

Khanthiilas
Level 1
Discord Link Steam Link Newsletter Link Kickstarter Backer Weaponsmith (Bronze) Armorsmith (Bronze)
1 year ago

so i have made two attempts but I can't get past the load screen to get sworn in but I have to say I love the stories tutorial at the beginning of the game that was awesome, any suggestions its just hanging and saying loading for more than 10 minutes.


Evil Triumphs when good folk do nothing. Also... Your toast is burnt and no amount of scraping with remove the darkness.

Oinkus
Level 3
11 months ago (edited)

Game stuck on loading screen won't progress. Tried a different save still loading more then 5 minutes. Will try a new game next and do the tutorial yet again , annoyed.

JediOkie
Visitor
11 months ago

I'm creating a wizard class character and it's stuck on the spell screen and won't load the Identity screen. If I click on previous it flashes but never actually lands on that screen. I've cancelled the character creation and started over and get the same issue.


Oinkus
Level 3
11 months ago

Restarted computer tried the first save and it started. The first loading screen takes a minute also now. No idea WTH is going on but it is running.

Eldan
Visitor
11 months ago

My computer crashes, when I examine the totem in the orc cave after lighting the two torches. It has done so twice

Mindbender
Level 5
Discord Link Newsletter Link
11 months ago

so i have made two attempts but I can't get past the load screen to get sworn in but I have to say I love the stories tutorial at the beginning of the game that was awesome, any suggestions its just hanging and saying loading for more than 10 minutes.


Same with me but it worked on the second load

sephbp
Visitor
Discord Link Newsletter Link Kickstarter Backer
11 months ago

I have encountered the bug where, post-cutscene, the camera is trapped in a wall/in some part of the environment and I cannot move it.  What is the best way to remedy this?  Reloading the save?  Restarting the game?

Kharnacier
Visitor
Kickstarter Backer
11 months ago (edited)

[RESOLVED?]

Hi,

I fought some spiders in the Library and got teleported in the Crown Room where 3 dead soraks lie dead.

I can't go out and have to fight 5 soraks (one is a sorcerer)... Is that normal ?

I've beaten the soraks but the quest doesn't update: "Explore the Ruined Tower : Kill the Soraks" ... :@

I've used a previous save and finally got past the spiders bug...

Daniel Wynn
Visitor
Steam Link Kickstarter Backer
11 months ago (edited)

Double-clicking on a character to jump to the said character while the party is split causes the game to freeze on a black screen with no UI instead of moving to the character. Moving with ASWD does seem to fix this, however.


Wherever you go, there you are!

bandit424
Visitor
Kickstarter Backer
11 months ago

Not sure if it was just a specific situation thing but the first time I cast Flaming Sphere there was no visual depiction of the sphere but I was able to use my bonus action to move it and damage an enemy, although again there was no animation and it lagged/took so long to do the attack I was worried my game crashed (and as this was near the end of the EA, I never risked casting it again).

I also noticed when I ritual cast (both Detect Magic and Identify separately) and was brought to the ritual cast screen sometimes it would never go away; the only way I was able to fix this was by pressing ESC (which brought up the save/load/quit game menu perfectly fine) and then closed that ESC menu again which would fix the pause and bring me right out of the break and reload the dungeon and cast the spell ritually all fine.

In situations where enemies are walking up the to party, like the ghouls after you investigate the front door of the Bone Castle, if you try to move up to them/stealth before combat starts it was possible for both the enemies to start inside each others square or for them to overlap on a player's square. Im not sure this caused any problems for the enemy AI, but the former did make it hard to target one of the overlapped enemies and the latter situation of being stuck inside an enemy meant that my character couldn't move nor attack the creature in their own square (although they could attack others), and required my companions to target and kill the ghoul to free my character

And finally, when my Ranger (with the subclass with the reaction shot and poisoners kit, forgot the name) got to use their reaction shot on an enemy making the ranged attack, even if it killed the enemy their attempted shot would still roll (although not actually be made) and would be stuck on the screen for a bit and may have caused issues when the turn tried moving over to a new character

11 months ago

So the first day of playing for me went fairly well, but then the next day I've run into some serious game breaking issues.


First, my game seems to freeze whenever I open up the map screen. If I try to travel using the map, it puts me in a never ending black screen.

Additionally, whenever I leave an area, there is a chance I get stuck in a loading screen. Either the game crashes/freezes OR what has happened in several different saves, the visual is of the screen, but the game is running behind it (I can hear audio beeps when I would mouse over something).

I've also run into a quest that I think is bugged. It's the one where you speak to the Scavenger lady about the old adventurer/scavenger. You have a chat with her, and the conversation ends, but she still has an arrow over her head, but with no new dialogue.

On top of that, there is a "Quest for Information" which said I had completed all of the tasks, but didn't complete or give me anything else to do.

When the game was moving smoothly I loved it, but I cannot get past these bugs. 

Kiaraash
Visitor
11 months ago

Hey, pretty game you did here. 

Brought you some bugs that spoil game's shine. All the screenshots to troubles (with numbers) are here . Sorry for my English. >.<

1st group: troubles with text and subs:

   - 001 this part of text does not belong here.

   - 002 in scroll creation window scroll name for "Jump" scroll is wrong.

   - 003 text is lost

   - 004 "should not be displayed" feat is displayed.

   - 005 text is invisible or lost. We touch the book. Nothing happens.

   - 006 text is lost

2nd group: troubles with textures:

   - 001 someone is buried alive here!

   - 002 we kicked this column in magic tower. Nothing happened visually. But later we walked by air in the very place where this column should have been misplaced to.

   - 003 and 004 we can see all the dark castle map. Even those places we haven't visited yet.

3rd group: interaction with objects:

   - 001 we cannot make magic weapon to fly as far as possible to shorten the distance with enemy if final point of the magic weapon route does not hit the ground in one turn. 

   - 002 and 003 this old tree stump is marked as basket on the map. And we cannot interact with it.

In the dark castle all outside holes lead to the same point in the same dungeon. (not sure if it's a bug)

Casting "Fog cloud" from scroll stops the game. Everyone is stuck in the moment when caster stops reading the spell.

Every time i need to take the loot and distribute it personally, the list of items in inventory of my strongest hero stacks with loot. That makes the loot impossible to loot until I scroll all the item list in the said inventory to its end. Annoying...Also I had the same bugs with old scavenger man story and that strange place with chest in magic tower where we could not get to, no matter what we tried. We didn't have "fly" and "spider walk" at that time. But now we are 5th level and EA is over for us we can't go back ant try these spells...

11 months ago (edited)

A few minor issues, but some more pressing ones for me

- Is dual wielding working correctly? I have a rogue with a rapier and off-hand dagger - I have never seen the dagger make a an attack roll, even though both are equipped. I think this may be a bonus action, but it doesn't show up under the bonus action menu either (unless I'm not seeing it for some reason). 

- occassionally the party can't be moved. Not sure what triggers it - but I can select a unit, but not direct them anywhere (or use any of their abilities). turning 'cautious' mode on and off seems to fix it for all characters.


Evgeniy
Level 5
11 months ago

A few minor issues, but some more pressing ones for me

- Is dual wielding working correctly? I have a rogue with a rapier and off-hand dagger - I have never seen the dagger make a an attack roll, even though both are equipped. I think this may be a bonus action, but it doesn't show up under the bonus action menu either (unless I'm not seeing it for some reason). 


rapier  is not "light" weapon, try to use short sword or another light weapon.


Evgen