Data Corruption - What to do if you're stuck in Infinite Loading Screens

2 months ago

What simply solved mine is there are two solutions. When I got stuck at LAVA FOREST.

Did the steam verify thing.. no hope.. so..

Lowered all graphics, once I am at the cabin after the battle on the dragon, I saved. Closed my Solasta. Open again, and simply reload the game. Done. It took me back to the map. 2nd, uninstall solasta Steam version, install GOG, get out and save it once you got out where you were stuck and install steam version again. Load the game. Hope it helps. #lennic24

1 month ago

Sup Devs,

I've diabled steam game synch, uninstalled, deleted al files at %appdata%/locallow/tactical adventures, reinstalled the game, verified game files, and it's still stuck at 90%, I cannot get into the game.

I've checked I have windows media player installed, I have up to date drivers (AMD Radeon RX 5700 XT), and I've deleted the cotmintro mp4 file, and renamed it. Hell I even tried disabling all the DLC, no change.

please, let me play the game, help me :( I've got all the DLC and everything