Data Corruption - What to do if you're stuck in Infinite Loading Screens

1 year ago

Yeah this is only helpful if you have the steam version and can access the beta. As far as I'm aware, there is no way to do this on the Microsoft store version. This should be addressed or brought up to them maybe?

Level 9
Steam Link Newsletter Link Kickstarter Backer
1 year ago

From the patch notes:-

"The Beta Branch is only available on Steam as maintaining multiple builds on multiple platforms is very time consuming, and we prefer using said time on testing / fixing more bugs."

1 year ago (edited)


I'm also getting a constant ERROR:LOADING FAILED when I am trying to get into the grounds of the Fortress of the shield.
I can teleport inside the fortress but once i try to go outside the error appears.
The same happens if I travel to the fortress.

I have VERIFIED THE FILES ....all seems well

I have REINSTALLED the game....That didn't work 

I have lowered and disabled the shadows and graphic settings as per a previous answer to this problem...That unfoirtunately doesn't work for this either. 

I'll try the Beta version and see if that works

Thank you

1 year ago

Hi Devs,

I have recently received patch 1.3.55 on GOG/PC and this has resolved my issue where I was unable to leave the Fortress of Shield.

Thanks for the quick turn around.

1 year ago

hello, I have this error, I have already performed all the procedures suggested there in the link, as it did not work, I uninstalled the game from steam and installed it on a zeroed computer to see if it was my PC, but the error remains, what should I do now?

help me!!!!!!!!!!!!!!!!!!

1 year ago

So I ran into this problem today where my game crashed, and since then I have constantly been getting this error code about the game files. I uninstalled and reinstalled this game via Steam and even after that it had no effect, it seems. I even removed it from my PC and then went to Xbox to download it via gamepass and was still getting the same thing when I downloaded the base game itself and I am just flabbergasted. 

1 year ago

It's not starting up at all. Data corruption error, asking me to verify integrity, which doesn't work at all. I have tried to reinstall several times. Verified at least 10 times, no dice. Error occurs in startup loading screen. Gives 2 options, Quit game, or directs me to a website. I cannot even click on those options, mouse doesnt appear. Can't alt-tab. can't initiate the task menager. Have to shutdown by the button whenever this error comes up..

Game is gone. Please Help.

1 year ago (edited)

I played for about 20 to 30 hours before with no issues and no having a problem loading the game.  It has the splash screen and has the spinning "Loading" in the right corner that runs forever.  I left for 2 hours on that screen to see if would load and it did not.  I attempted to uninstall the game in Windows add remove and reinstall, I also attempted to do the same with the Xbox game pass application.  I attempted to repair files.  None of this has worked for me.  Please advise as I cannot play the game at all in this state.  I've purchased all available expansion packs looking forward to playing, but at this point I am at a lost what to do.

The screenshot shows the progress bar just sits and does nothing.  

Level 14
Steam Link Newsletter Link Kickstarter Backer Weaponsmith (Bronze)
1 year ago (edited)


Note that your image is not a URL at all.  
The forum does not take a drag/drop that you might see, but no one else will see it.

It has to be a full Internet adresse (URL).

Steam profile :

1 year ago

Okay thank you for the information.  The screenshot showed the splash screen with the loading circle and the progress bar about 70 percent full.

I finally got the game to launch with uncommenting the following from the MicrosoftGame.config file. 


    <Executable Name="Solasta.exe" Id="Game" TargetDeviceFamily="PC" />


            IsDevOnly="false" | IsDevOnly specifies if is a Development only executable.

            OverrideDisplayName="Xbox Game Override"



            OverrideSplashScreenImage="SplashScreenOverride.png" -->

I'm now getting the error message "Cloud Save Failed"  But at least I got the game back working with the save games I had originally.  

1 year ago

I finally got this working!  I installed and reinstalled the Xbox Application.  That did not work, so I stopped the "Gaming Servies".  I attempted to start the services but had the error "Invalid parameter" After restarting my machine to get the services started (They were set to start automatically).

The game then synced the save games with the cloud and started up normally without the tweak in the MicrosoftGame.config file.  

It seems the Xbox app was causing some issues with syncing saves.  Other games I attempted seem to work but not try to save a game or anything.  I updated to Windows 11 from Windows 10 recently and from what I've been reading that caused some corruption in the Xbox app.  Hopefully this will help someone else who might be having this issue.  

Level 1
1 year ago

I have tried all the fixes that people have said that works for them, I have been at this for about 2 hours and I cannot fix it. Any more help would be appreciated. I am trying to play on steam. 

9 months ago

On Steam..have the infinite loading screen, have tried all fixes listed in this thread. I have no mods installed.  I need a legitimate fix, is there one?

9 months ago

I got the corrupted files bug as soon as I tried loading a battle save with Kythaela using her Shadow Dagger cantrip during battle. Luckily I have a save before I initiated combat so I just loaded that. It was a battle against two minotaurs on the same map a bit north of where I found her and she joined my party. I tried the battle again and used her cantrip, saved, loaded and got the same bug. So I just reloaded the save before I initiated combat(I did not do the "verify files integrity fix" and just loaded the save) and finished the battle and all other battles without using Kythaela (I just let her hang back and skip her turns). I'm currently doing her quest line, so i'll just finish it without her assisting in battle since I think she is causing the bug.

I'm playing on steam with Version 1.4.30