Data Corruption - What to do if you're stuck in Infinite Loading Screens

Tactical Myzzrym
Level 14
Tactical Adventures Dev
Discord Link Steam Link Newsletter Link Developer Badge
1 month ago (edited)

Hello there folks!

Are you having issues with loading screens? As in you sat there for more than 10 minutes, had time to get a coffee, thought about your life and mused about the meaning the universe? If that's the case, we potentially have a solution for you. Read on!

Solution #1: Wait a bit more

  • This may sound dumb, but Solasta being in Early Access and all, it's not very well optimized yet! If you only waited for 2-3 minutes, it's possible that your computer is busy processing other things, like trying to load a website on a navigator your forgot to close or downloading another game on EGS, Origins, Uplay, GoG... (good lord that list is getting longer every year).
  • That being said after waiting 5+ minutes or getting an error message you can consider that long loading times aren't the problem anymore - you're stuck!


Solution #2: Verify your Game Files Integrity on Steam

  • Sometimes, Steam doesn't download the patch properly but still pretends that the download is finished (Steam with those Nat 20 Deception rolls). Because of that, your game is effectively corrupted and you'll end up running into an infinite loading screen at some point - or even just when launching the game.
  • Verifying your Game Files Integrity forces Steam to re-check the game folder, and download the missing files when it realizes it made a woopsie.
  • To verify your Game Files Integrity, simply:
    • Make sure you quit the game before doing anything
    • Open your Steam Library
    • Right click on SOLASTA Crown of the Magister
    • Click on "Properties..." (at the bottom)
    • On the top of the Properties window, select "Local Files" (3rd tab)
    • Click on "Verify Integrity of Game Files..." (4th option)
    • Done! Now you just have to wait for Steam to verify / download the missing files


Solution #3: Use another save files (only do that if Verifying Game Files Integrity didn't fix your issue)

  • Sometimes, you did something during your run that the game didn't like - but the game doesn't crash. Those small error messages (hidden from the player) can range from harmless issues to "errrr chief, you just broke the game". Since the game doesn't crash outright, you can keep on playing - but as DMs like to say "you'll eventually run into the consequences of your actions" (even if it's not your fault in this instance, you couldn't have known). Meaning you'll eventually run into a crash, or an infinite loading screen. If that's the problem, verifying game files won't help. 
  • Often what happens is that you'll save AFTER you already did something to break the game, so loading that particular save won't work (you'll always run into the same infinite loading screen)
  • The solution is to load an older save - unless you disabled them, the game should auto-save fairly frequently. You can simply try to load the previous save and see if you still run into the same problem. If so, load a save that's even older - rinse and repeat until you finally find a save that's not affected by the infinite loading screen.
  • At the very worst if nothing else works, you'll have to start again from the beginning :(
bigtenor62
Level 4
Steam Link Newsletter Link Mayor's Ring (Bronze) Weaponsmith (Bronze) Armorsmith (Bronze)
1 month ago

Mine takes about 8 minutes to start. That's ok cause my desktop is not the fastest. I know it won't play Baldur's gate 3 but it runs divinity original sin2 quite well and one of the helpful people here said that if it runs DOS2 it will probably run Solasta. I'm so glad it does. Once I 've made the initial load to play ( about a minute or so) it actually loads much faster (about 30 seconds) if I want to reload a save.



I just thought I would include my system specs for those who are having long loading times. 

To those who are experiencing long initial loading times compare these specs to your own system

 ( probably most everyone's is faster that mine(( 8 minutes initial load)) lol. if yours is faster, just be patient.



Operating System
Windows 7 Home Premium 64-bit SP1
CPU
AMD Athlon II X4 640 36 °C
Propus 45nm Technology
RAM
16.0GB Dual-Channel DDR3 @ 666MHz (9-9-9-24)
Motherboard
FOXCONN 2AB1 (CPU 1) 31 °C
Graphics
SHARP LCD (1400x1050@60Hz)
1023MB NVIDIA GeForce GT 640 (PNY) 35 °C
Storage
931GB Western Digital WDC WD10 03FZEX-00MK2A0 SATA Disk Device (SATA ) 31 °C
Optical Drives

Papapug
Visitor
1 month ago

after completing the quest for the 1st jewel everytime i tart game this comes up any idea what i can do 

[Exception] NullReferenceException: Object reference not set to an instance of an object


GameQuestValidatorItemUsed.Register () (at <9130be54a7504c83bb3ffc3c86a7e517>:0)

GameQuest.GameLoaded () (at <9130be54a7504c83bb3ffc3c86a7e517>:0)

GameQuestManager.GameLoaded () (at <9130be54a7504c83bb3ffc3c86a7e517>:0)

SessionState_LoadingSave.CampaignEntered () (at <9130be54a7504c83bb3ffc3c86a7e517>:0)

GameCampaignManager+<LoadCampaignVisualAsync>d__27.MoveNext () (at <9130be54a7504c83bb3ffc3c86a7e517>:0)

TA.Coroutine.Run () (at <9130be54a7504c83bb3ffc3c86a7e517>:0)

UnityEngine.Debug:LogException(Exception)

Trace:LogException(Exception)

TA.Coroutine:Run()

GameCampaignManager:Update()

thanks

bigtenor62
Level 4
Steam Link Newsletter Link Mayor's Ring (Bronze) Weaponsmith (Bronze) Armorsmith (Bronze)
1 month ago

I was fine until I tried to go to the tower of magic. 

I got stuck in the infinite loading screen. I finally gave up and started a new game.

Hopefully that will work.

Aethersworn
Level 6
Discord Link Steam Link Newsletter Link Weaponsmith (Bronze)
4 weeks ago

I started a new game after the latest patch and was fine until I tried to leave the tower of magic. I suspect I might have broken something there by explorintg further in before following the light to the locked door in the tower, but I'm not sure.


I'm a roleplaying and worldbuilding enthusiast who appreciates the weird and wonderful.