Critical exception when looting & spot by enemy

Redglyph
Level 12
4 months ago

In Bone Keep, Dark Castle, after the 6 steps of the maze, there is a Wight near a basket, NW of the floor (must climb a push crates to get there).

The character opened the basket to loot its content and the Wight sprang at the same time.

A 'Critical Exception' with the following data occurred at this instant. It was still possible to play: combat and defeat the enemy, move around. But mechanisms like wall torches, doors and so on were very slow to react. It was impossible to save the game from that point on.

I couldn't see the loot panel, I directly had this message:

[Exception] NullReferenceException: Object reference not set to an instance of an object


CursorLocationBattleFriendlyTurn.Activate (System.Object[] parameters) (at <9130be54a7504c83bb3ffc3c86a7e517>:0)

CursorManager.ActivateCursor (System.Type type, System.Object[] parameters) (at <9130be54a7504c83bb3ffc3c86a7e517>:0)

CharacterActionPanel.RestoreDefaultCursor () (at <9130be54a7504c83bb3ffc3c86a7e517>:0)

CharacterControlPanel.RestoreDefaultCursor () (at <9130be54a7504c83bb3ffc3c86a7e517>:0)

FunctorInventoryLoot+<Execute>d__0.MoveNext () (at <9130be54a7504c83bb3ffc3c86a7e517>:0)

TA.Coroutine.Run () (at <9130be54a7504c83bb3ffc3c86a7e517>:0)

UnityEngine.Debug:LogException(Exception)

Trace:LogException(Exception)

TA.Coroutine:Run()

GameGadget:Update(Boolean, Boolean&)

GameSector:UpdateGadgets()

GameLocation:UpdateGadgets()

GameLocation:UpdateLocation()

GameLocationManager:Update()




Redglyph
Level 12
4 months ago

After a reload, I first killed the enemy then looted the same basket without problem.

Jatea
Visitor
4 months ago

I also had the same issue, set off in the exact same way except I never saw (or just didn't notice) the Critical Exception.

I had a 4-cleric team, all in cautious mode, and we all snuck up to the basket, not knowing that there was a wight there. The leader tried opening it at the same time that the suspicious-meter filled all the way up to hostile, when combat happened.

After that battle, saving was also impossible for me, there was a permanent at least 5-second delay for interacting with objects, and the basket that we tried looting never opened the loot screen.

It didn't fix even after future battles, and I never got autosaves where I assume autosaves would have happened. I luckily had a manual save right before the single wight.