Corruption occuring in save files due to odd bug on first entering new area

e.hough
Level 2
1 month ago (edited)

For the last couple of days I have been encountering two odd issues while playing that originally did not seem to be related. The first issue was that I noticed when first zoning into a new area you started out in an odd state where none of the party was selected and while in that state you couldn't do anything but pan the map. Once you either selected a character (by F# button or mouse click) or clicked on the group selection icon everything worked normally. 

Second problem - I would randomly have problems with a save file showing up as corrupted when I tried to load it. Nothing I did would allow me to load the file so I just went back to an earlier save and continued playing. I finally had several of these corrupted saves apparently in a row, including some auto saves that had the same corruption. I finally traced it down to the previous issue - if you have just zoned into a new area and you save while still in the "no character selected state" either by a quick save, an auto save or a manual save the save file will be corrupted. I currently have 2 game files that illustrate the problem - 'Corruption Test Save 1.sav' was made right after zoning into the new area and is corrupted, 'Corruption Test Save 2.sav' was made after I selected the party. I will email the files.


Game Version 0.5.42

Game Location: Manacalon ruin you stop at after first picking up Kithaela in the Monastary ruins, however any map should work for this.