Constant multiplayer Desync

8 months ago


First of all I would like to congratulate the devs for creating such a fun and engaging game. I've been playing on multiplayer with a friend and most of the time we are having a blast. 

The only problem we keep having is the desyncroniztion. Usually its happens in the middle of combat, specially on the swamp area, random encounters or when we use the "conjure creature" spell (after the conjured creature's turn).

When this happens the combat get stuck on some random creature or player's turn, but sometimes the combat continues  with different outcomes for different players, which forces us to reload the last save.

I hope devs can manage to give this problem a solution, because the rest of the game is amazing.

Level 9
Steam Link Newsletter Link Kickstarter Backer
8 months ago (edited)

A fix has just been released on the beta branch of Steam that has some more de-synch fixes.

8 months ago

I am also experiencing this issue playing with a single other player in MP. We were using the beta for the Shield enter/exit fix but we swapped back to the standard build after the patch was released. At this point it's almost guaranteed that during every combat we will desync within the first 3 rounds and have to reload at which point the second attempt will usually get us to the end of combat. If we weren't able to save during combat the game would be borderline unplayable :-/

We recently had a game where we determined that the spiritual weapon was causing issues every time it would swing. The swing would take a very long time to resolve and after the resolution we realized that we were somehow playing different instances of the game but in multiplayer and in the same turn order. We were watching each others streams on Discord and saw that the dice rolls and outcomes were different for each of us. The game managed to re-sync itself after a full round completed.

Level 1
8 months ago

I have come across this same issue as well recently.  Playing with one other player, we first noticed it when we were in combat.  My druid cast Hold Person on two enemies.  I saw that enemy A failed, enemy B succeeded.  She saw that A succeeded, and that B failed.  When she attacked enemy A on her game, I saw her attack enemy B.  

Since then, when looting certain containers, she looted a box first, getting the contents, and giving one of the items to me. I saw no items gained or transferred, and when I went to the container after I saw the items still there, unlooted.

Now, in another combat, my game tells me it's her character's turn, and her game says it's an enemy's turn. The initiative is rolled and completely separate for each of us. And we can't progress, because she can't take her turn and the enemy won't take it.

When she leaves the game, everything seems to realign to my game's timeline of events, with nothing that she had done carrying over(equipping certain items). It's a little frustrating.

This is screenshots of her and my game's during said second combat.  Her game My game

Level 3
7 months ago (edited)

We had a multi with 3 human player yesterday and had 2 main desync.

First as mentionned , the combat turn was always desync, 2 were in sync and the third not .

we loaded and saved a lot ;) . Finally something comes in our mind .

As , in the process of making it works we changed the server pc . 

First, it was a custom campaign . Interdimensional Escalations  .

we were 3 players and then have one who played 2 characters .

Say player 1 is P1, Player 2, P2, and P3 is player 3

When creating the campagin we were on the PC of P1

Then had some issue regarding the "photon" thing and was unable to start the game correctly .

Then P2 created the game . P2 controls 2 characters,p1 and p3 ,one each .

then after some few minutes, P1 continue to have deconnection . then P1 tried to find a solution and found one that worked. It was a new wifi network and used finally another one (he has 2 wifis network at home) .

Then we decided to save the game and P1 became the server again .

P2 sent the savegame to P1 (yeeah it's a long story but hey...that's always ;) )

P1 loaded the multi saved game and had the ability ,in the loby, to attribute the 2 characters that was played by P2 to P2...then he does.

then P2 controls again his 2 characters, P1 and 3  their only one. The only difference it that P1 is server again .

Then first combat and the turn was desync for player 2 . Player 1 and 3 turn was correct . Then save/load . the combat passed . second combat ...same ...third ....same ...Then we said " it's not playable" ... in fact the Game was inverting turns ...then we came to conclusion that when we create a party as server , the server have the ability to control 2 characters ... not the clients ...

but when we load one, the server have the ability to attribute 2 characters to a client....that could be the problem of those desync. For a reason that is not clear , the game make the turn as if the 2 controlled characters was controlled by the server player...not the client ...

Then we decided to reload the game again by the P2 who had created the game ...and no more desync in combat...

we played 2 hours without desync in turn . But at the end of the session we wanted to exchange some stuff from one character to another and founded that the stuf was not receive by the good characters.

Character 1 = C1 , character 2 = C2 , etc .

then P2 that is the server have C1 and C2 , P1 have C3 and P3 have C4

when C1 sent a potion to C3 , C3 had nothing and C4 received the potion .

But for P2, when he looked at P1 inventory he saw his potion .

But for P1 and P3 the potion was in P3 stuff ... 

then P1 looked a P2 stuff and here it the magic ...

While P2 was moving objects in the inventory of C1, P1 and P3 watched the same inventory of C1 but objects that was moved "mutate" in other object ...say it was a potion and became a book ...or a scroll ...LOOOOL ... P2 was creating object just by moving them ...and we said ...ok, it's time to go to bed guyz !!! ;)

....HAAAAVE FUN Tactical Team!!! ;) ...

But really it was really fun , even if it was buggy ! :)

6 months ago

Brand new players here 3 of us. we keep getting descync and My pc keeps getting photon cloud issues. This is very annnoying 

Level 2
5 months ago

Firstly, thank you so much for adding multiplayer. I hope you're all still working towards tightening it up. We all wouldn't be playing without it, and it's given us quite a bit of joy lately!

Three of us playing 3-4 times a week. Since the last patch, the desyncing has gotten quite a bit worse. Especially with respect to traveling combat and the first combat in a new area. It's always the same, whoever is hosting the game doesn't see what the other two are seeing. And we've tried 'passing' the save (having a guest save the game while in it and then we all restart with them hosting) and it doesn't seem to matter which of us is hosting, it always de-syncs the same way.

There is also de-syncing related to passing items between a host character and a guest. We try to always remember to save before we start passing things around, and a receiver of an item should 'never' have their inventory open when getting an item. When the de-sync happens, either the host is passing and item and sees the guest player's character received the item in the log and the guest doesn't, or a guest is passing to them and sees the log entry, and the host doesn't. The latter is more scary, b/c we have to do a reload from a previous save. In case of the former, the host can save and when we reload, the guest character has the item.

2 months ago

I now this is an old post, but just wanted to chime in that I and a friend have recently been trying to play this game and we have been having several issues of desync also. I play on Xbox SX and he plays on PC through Xbox game pass.

1 month ago

Four players. Constant desyncing almost every battle. It gets very tiresome to have to reload each combat desynchronization, only to need to do it once again when a new initiative is rolled or someone loots... or someone has a turn. It's just about unplayable with more than two players. Three is asking for it and four - it has brought the game to a standstill, going a couple of rounds, then waiting five minutes (no joke) for each reload.

Please, please fix these issues!