Constant freeze before (and after) combat

Leakimka
Level 3
Newsletter Link Kickstarter Backer Armorsmith (Bronze)
7 months ago

Whenever a combat is starting, the game freezes for some time, usually 1 or 2 mn. If I click anywhere, Windows gives the "Close the program or wait for it to respond" message.

Interestingly enough, the freeze seems to occur exactly on my first character turn: if one of my characters has the best initiative score, the freeze happens immediately at the start of the combat ; all bad guys playing before my first character can run their turn normally.

The Same issue also happens at the end of the combat.

PS : just sent an email with my save file and more technical details

6 months ago

I'm also encountering the constant game freeze at the start of combat, whenever I save, and coming out of cut scenes.  It's like it gets stuck in a forced pause.  If I click anywhere (just once), I get a loading circle and about 10 seconds later, the game is responsive again.  If I click twice, I get the Windows "close or wait for it it respond".  If I don't click at all, it stays frozen.

Is there a fix for this?  


I'm not laughing AT you, I'm laughing WITH you. You're just not laughing.

Leakimka
Level 3
Newsletter Link Kickstarter Backer Armorsmith (Bronze)
6 months ago

To follow up on this bug, it seems that the Spring update almost solved it: the freeze of 1 to 2 mn I was experiencing has decreased to a lag of few seconds, occuring in the exact same conditions...one more little effort, guys! ;)

Leakimka
Level 3
Newsletter Link Kickstarter Backer Armorsmith (Bronze)
5 months ago (edited)

Today (May, 19th 2021), Nvidia updated my driver through GeForce Experience to version 466.47 (my GPU is a GTX 1660 Super) and since then, the same bug is back! Freeze now happens before combat and after, but also before and after some other animations...any clue?

Edit : game version is 1.0.13