bugs

Keppie
Level 1
Kickstarter Backer
3 weeks ago

1) monsters regularly display no animations in a fight while acting on their turn. This is always combined with their turn taking much longer to finish while they just stand there. Annoying.

2) Faction rep for the tower of knowledge can be gotten to infinite by just repeating the selecting the same dialogue option over and over again ("Just checking in to see how you were doing")

Funny, but supposedly unintentional ?

3) items disappear from the party stash. And no, I didn't drop them on the ground because I tried storing them with a different character that opened the stash, which is a retarded mechanism btw

Inexcusable

4) At least sometimes, possibly always, when casting protective spells with an extended duration seconds before a fight (duration 1h and above), those effects disappear upon starting the fight. Same for potions. Inexcusable, durations should work as described

5) Certain movement during battle is sort of broken. Upon selecting a position at the edges of the screen (but still clearly visible and the mouse pointer hovering over), it is impossible to select until you rotate the screen to move that position away from the screen edge. May be related to the fact I'm using an ultra-wide monitor ? Annoying as hell

6) Handling of food seems off. I ran out once with no food spell selected or scrolls in inventory and could continue travel for an extended period of time without finding any new units or my party status being impacted in the least. Still 'fresh' after a week without food ?

Minor I guess, but still invalidates everything in the game related to food..

7) Characters should be able to access the inventory of their unconscious and/or dead comrades. The game itself clearly allows it when looking for possible "raise dead" scrolls or the likes after a fight if one or more characters died, but it does not allow players to do the same (to get a potion or something from someone to heal them back up). What if the unconscious guy carried the last potion ?

On the other hand, a short or long rest will bypass these problems which is ridiculous. Why not let it behave properly from the start ?

8) During gem quest : the mind of the master, i cannot make camp due to lack of food. Why ? My cleric has create food in his spell list with no slots used. Why does this work at all other times but not during this quest ? Noticed this at least twice : at the campfire in the master's manor and at the campfire to which you're teleported back after killing the dragon

9) Ring of the lord inquisitor clearly mentions 2 charges of "hold person", 4 of "dominate person" and 3 of "hold monster". I used one charge during the dragon fight in gem quest : the mind of the master and any options related to this ring became unavailable to me whilst I had no active concentration spell...

10) During the gem of the master quest (again), at least three times, different dialogue was displayed with the subtitles than what was actually being said.. This one's probably the least annoying, just very noticeable.

These are what I can remember off the top of my head, sadly there's more. Sorry to say, but this game should get some serious polish. On top of the bugs, it's just way too restrictive in general. Some of that stuff feels like a minimal effort kind of thing (Do it the dev's way and none other). AD&D's about freedom, being inventive and personal choices though. 

It's a shame really. There's something good underneath it all, but it's far from shining yet. Especially for this price tag. Personally, no DLCs for me until it does. 


Yowz