Bug in Lost Valley in the first secondary mission

anarion321
Level 2
5 months ago

At the very beggining you got a mission to deliver antiquities to a person, I've got the mission on the journal, I've got 2 antiquities, the journal updated saying that I found the items, but I cannot deliver them, If I move forward, the mission fails.

In my first run I was able to deliver them, I did not like a thing about my characters and I restarted it, but now I got this bug.

5 months ago

Hi!

There are 3 Antiquities that need to be found in order to complete this quest!

If you still cannot complete the quest after gathering all three, could you send us a save file? This will help us find out what could be causing the issue you are experiencing!

You can find where the save files are located (and where to send them) by following this link: [IMPORTANT] Rolling Bug Report... | Forums | Solasta: Crown of the Magister (solasta-game.com) 

anarion321
Level 2
5 months ago

Hi!

There are 3 Antiquities that need to be found in order to complete this quest!

If you still cannot complete the quest after gathering all three, could you send us a save file? This will help us find out what could be causing the issue you are experiencing!

You can find where the save files are located (and where to send them) by following this link: [IMPORTANT] Rolling Bug Report... | Forums | Solasta: Crown of the Magister (solasta-game.com) 

Thanks for the response, it seems that I was lacking the 3rd Antiquitie, I examined everything, but after doing it again I found the 3rd, maybe the roll was unsuccessfull the first time.

Thanks a lot!!!!