[BUG] Game launches on an empty window, can hear the background music

Artinius
Visitor
3 months ago

I had no problems with the game a few months ago. Yesterday i bought the two last DLCs on Steam but couldn't manage to launch the game. When i launch it, an empty window appears with only the Title Bar displayed. After it loads for a few seconds i can hear the Menú Music but i'm unavaible to do anything.

What i see when i launch the game

I tried multiple settings. I disabled each DLC, one by one, but i still got the same problem. Then i tried this three Betas available:

Available Betas

First i verified the integrity of the game files and then i reinstalled the game. None of the solutions above worked. I have no issues with other games, my computer specs are:

CPU: i5 6300

GPU: nVidia GTX 1070 Founders Edition

Motherboard: z170x-Gaming 3

But as i said, i had no issues running the game a few months ago before Primal Calling release. I really wanna play this game, i hope i can find the solution so i don't have to refund it due to technical issues :'(

3 months ago

Hi!

There are two potential reasons for this issue to occur:

  1. This could be an issue with the version of Unity used to run the game. If that is the case, you may need to install new drivers for your hardware.

  2. This could also be an issue with the game not using the correct settings upon launching. If that is the case, you can delete a file called UserPreference in the Solasta game files and launch the game again.
    If this file is missing, Solasta will launch using default settings and recreate the file afterwards.
    Do note that this means that you will lose all your settings and will need to change them again (for instance: the resolution, language, or audio settings will all revert to their default).