Bug Dungeon Maker, Custom Loot Pack

2 months ago

I've recently gotten interested in creating my own Campaign, and are learning about Dungeon Maker by following SirMadness TV's very helpful DM series. 

Although I am a new user of the Dungeon Maker, I'm sure this bug report isn't caused by the typical new-user finger trouble.

In SIrMadness's Tutorial 7, he starts developing a Campaign (as opposed to an individual Location), setting up Custom Items, Monsters, NPCs, etc. All was going well with my slavish copying of what he was doing, until we got to (Custom) Loot Packs.

Following SirMadness's instruction, I clicked on "+ New Loot Pack", used the same "Internal Name" he did, and the same "Title". Then I did "Add Item" twice, to add two of the Custom Items SirMadness and I had already set up in this Campaign. Then I hit "Apply".

The Campaign Creator page, under "Loot packs (1)" had the entry for my just-created pack, but it had the fatal error signal (an exclamation mark inside a red triangle) at the far right of the row. When I moused-over the warning, the popup read: "The internal name for this content clashes with that of another user content or internal Solasta content. Chose [sic] another internal name."

Note that this is the ONLY loot pack I have created, so it can't be clashing with anything else I've created. Nonetheless, I have repeatedly deleted the loot pack and recreated it, using many different "Internal Names", including the default of "LootPack1", and 20-character random messes chosen by rolling both of my fists back and forth over my keyboard. I have also tried creating loot packs with no items at all, so just with the Internal name and title fields filled in. I invariably get the error triangle.

It's a fatal error, because when I create Chests containing the Custom Loot Pack, and playtest it, the chests are invariably empty when I had added several items into the loot pack.

I have loaded down and played a lot of campaigns created by other people, but I can't imagine that my new loot pack is clashing with any of them, especially because I tried some truly random internal names, and SIrMadness has me working within a Campaign of our own creation, not importing someone else's first.

Also, I usually run the "AlwaysAlt" mod, but turning it off and emptying the Mod folder didn't remove the problem.

I'm using Solasta "Version 1.4.33 - Public". If it helps, Steam says the App ID is 1096530, Build ID is 10260630.

I'm impressed by Dungeon Maker and am looking forward to eventually knowing how to write my own creations.

2 months ago

Sorry, accidentally posted this twice. Please use the other thread.

1 month ago

I had a similar error when I named a creature "Ghast" - it said that it already existed. I changed the name and it worked fine.  Maybe that will help you?

I also am working on creating an adventure after watching SirMadness's series.