1.1.8 BUG- Gem Quest: The Mind of the Master; Arena (SOLUTION/WORKAROUND)

Token
Visitor
1 month ago (edited)

The main door in this underground area appears to require the activation of two runes in order to open. I cleared my way through to the first rune, and then doubled back to the second rune that's locked away behind the Arena door. I walked into the Arena room, the cutscene triggered, and the door closed behind me. And then nothing. I can't interact with anything in the room outside of attacking the stalactites on the ceiling. From researching around the internet, I learned that the pillar in the center of the room (which highlights when pressing Alt, as appropriate) should have the glowing blue "transition" square at the base of it, which prompts you to move your party into that area to begin spawning the waves that must be cleared in order to open the door to the second rune so that I can progress. In my game, this blue activation square is not present, nor can I interact with the pillar to begin the Arena fight. As a matter of fact, mousing my cursor over the pillar shows a little X, indicating that I don't have permission to interact with it.

Upon doing some research, I discovered that this bug has been discussed numerous times on both the Steam forums and on these forums, as well as on various sites across the internet. Of course I'm saddened that I was one of those who has been subjected to a well-known and well-documented bug. I tried to troubleshoot a bit. Thank goodness I'm a habitual F5er and make many, many manual saves. So I loaded an earlier save and tried forgoing the activation of the first "free rune" down at the end of the long hallway, and instead tried to go through the Arena first, thinking that I may have accidentally performed a sequence break. I walked into the Arena, and the bug was still occurring. I backtracked to an even older save from before walking down into the shed tunnel to see if that made a difference, but unfortunately I was still running into the same issue; the pillar would not activate no matter what I tried.

As additional information, this is a fresh save with this version of the game, and a first playthrough with a fresh run. I did notice while randomly climbing around the small platforms in the room that one of my party members made mention of goblins? I took that to mean that there was some kind of event trigger that I had accidentally stumbled across, but something "under the hood" was broken.

I understand that sometimes these things do happen, but I have to say that I'm a bit disappointed that my run has been stalled out completely by this issue, specifically because it's been reported for months and has a long, well-documented history. I suppose I'll just have to keep my fingers crossed for a hotfix or a patch to correct this so that I can continue my playthrough.

I reported this in the Bug Report channel on Discord as well and walked through my troubleshooting there step by step.

I'll be happy to provide any other information necessary to resolve this as quickly as possible. Thanks for all of your hard work.

Token
Visitor
1 month ago (edited)

Ok, so I found a workaround. Apparently, it's possible to miss a cutscene that progresses the quest while you're working your way through the Forest area outside. If you don't trigger this cutscene, the quest doesn't progress to the next step that allows the Arena pillar to be triggered.

I decided to try to figure out a way to trigger the pillar, so I was working backwards through saves. I finally got frustrated because I wasn't making any progress, so I reverted to a save from just before walking into the arena. Then I walked back outside, and used the map waypoint to leave the forest and manually retrace my steps through the forest, and as I loaded into the first waypoint near the exit to the area, a cutscene triggered talking about having to stay patient and continue hacking through the weeds. Turns out that I had missed this cutscene because I bypassed the area where it triggers when I used Dimension Door to hop a barrier instead of just following the normal path.

The quest then progressed normally, I walked back down to the arena, and the blue "come stand on me to activate this thing" box popped up, and we're back in business. I guess it's possible to miss an event flag while walking around through the forest if you take a creative path, and doubling back to retrace my steps from the start snagged the trigger?

So if any of you stumble across this issue in the future if it hasn't been fixed yet, load into a save either before the shed or just after it (but before the arena so you're not trapped,) then go back outside, use your map to fast travel back to the very first forest waypoint where you walked in, and manually walk every inch of the forest, breaking down barriers as you go.

You should trigger any of the mandatory event cutscenes that you missed in order to push the quest forward, and you will activate the blue "stand in me to progress" square in the Arena and then be able to interact with pillar.