0.5.41 - hanging multiple times during character creation on clean install

chris.clark
Level 9
3 weeks ago

Last week I had to reinstall Windows. So I waited until after the update had dropped to re-install Solasta.  It downloaded the game and then applied a patch.  Started it up and everything is pristine.  No characters.  Help tip windows are all showing up again.

Clicked "New Adventure".  Clicked "Select" on the first character slot and then clicked "New Character".

Clicked on Dwarf and when I tried to click the arrow to change from Hill to Snow... nothing happened.  The game hung.

Alt+F4.  Start it up again.  This time I left it on Hill Dwarf and clicked "Next".  Clicked on Fighter.  The game hung.

Alt+F4.  Did the first scenario and again, the game just hung when I clicked on the arrow to change to Snow Dwarf.

It didn't used to do this.  This is new with the Spring Update.  (Or maybe because I have a totally fresh install?)

And by "Hanging", I mean that the music still plays, but nothing I click on does anything.  Cancel does nothing.  Clicking on a different race does nothing.  It's like all mouse input is getting captured and swallowed and not relayed to the game.

Had been hoping to try some of the new features, but...

Tried to create a character without starting a new adventure -- just making one for the pool.  This worked.  But then I started a second character, cancelled back to pool and then started a new character again.  This time it hung after selecting Elf.

Not sure why it's hanging so much, but it's really annoying. :(  Hopefully you can hotfix this quickly because it won't make a good first impression.

chris.clark
Level 9
3 weeks ago

Managed to make four characters eventually.  Got through the tutorial missions.  Got through talking to Lord Carran.  But the game hung while trying to load up the next area.  (The loading indicator just froze.)

Alt+F4.

When I tried to continue, the portraits where all just white rectangles.  The loading splashscreen came up, but then a Unity Error dialog showed for a second and then disappeared.  And the game hung.

Giving up for now.

Tactical Myzzrym
Level 14
Tactical Adventures Dev
Discord Link Steam Link Newsletter Link Developer Badge
3 weeks ago

Did you verify your game integrity on Steam? This sounds like the update failed to properly download the patch fully.

chris.clark
Level 9
3 weeks ago (edited)

Did a verify files on Steam, 100% okay.  Also updated/installed the latest video drivers (2070 Super) and updated/installed my mouse drivers (Logitech G600).  Started up game and figured I'd create some more characters just for the achievements.

Made a human fighter and got to the appearance screen and then the game just hung.  Had to Alt+F4 to exit.  I'm assuming it's something about my system, but I've no idea what...   The previous builds all worked fine.

Tried reloading my saved game and this time it actually loaded.  Got through the swearing in, but when I opened the map to fast travel... freeze/hang.  One odd thing is that when the game loaded, all of the portraits were white boxes.  The character portraits only appeared when I removed their armor and then put it back on.  That seemed odd.

chris.clark
Level 9
3 weeks ago

I have another game (Warhammer 40K: Mechanicus) that also uses Unity and it hasn't worked since I had to reinstall Windows, despite installing/uninstalling a couple of times.

So I was wondering if Unity is cooked into the game, or are there stand-alone DLL's that might be corrupt and affecting both games?  If Unity is a stand-alone utility, is there any way to repair it, or uninstall it so that it gets re-installed with a game?

chris.clark
Level 9
2 weeks ago

Update: Started a new game with new characters after minor update to 0.5.42 and so far everything is fine.

chris.clark
Level 9
13 hours ago

Played through an entire game with no issues.  Mechanicus also started working and I was able to play some of that.

Tonight I was playing yet another new game of Solasta.  Characters had got to level 4 and I was in a random encounter on my way to the Necro Tower.  I tried accessing a character's inventory while they were moving (after the combat) and the game froze.  After re-starting, the issue of the game just suddenly freezing returned.  Tried Mechanicus and it also is dying when I try to load up a saved game.

I did some Google searches and found something about setting aspect ratios in the nVidia display drivers.  Tried that and was able to create two characters.  Thought I had fixed the problem.  But... tried to create a third character and it froze again.  Checked Mechanicus and it also still doesn't work.

So there's something about Windows, possibly my display driver, possibly my mouse driver (it always freezes on a click) and Unity that aren't playing nice.  Doesn't seem to be a Solasta problem (other than it uses Unity) so I doubt you can help me.  But it prevents me from playing, so... big sad face. :(